Rss

  • youtube
  • google

Howto: QNAP HD Station und XBMC konfigurieren

Seit ein paar Tagen gibt’s die HDStation ja schon, aber vielleicht noch den ein oder anderen Trick. Deswegen schreibe ich hier mal ein kleines Howto, wie ihr auf eurem QNAP das XBMC richtig eingestellt bekommt.

Schritt 1: Aktuelle FW installieren
Ihr benötigt die aktuelle Firmware 3.8.1 welche ihr entweder als Live Update oder manuelles Update bekommt.
fw381

Schritt 2: HD Station herunterladen & aktivieren
Jetzt ist im Applikation’s Menü die HD Station verfügbar. Diese muss heruntergeladen & aktiviert werden.
enableHDStation

Schritt 3: XBMC herunterladen & aktivieren
Jetzt könnt ihr die “Apps” für die HDStation herunterladen. Neben XBMC gibt es noch den Chrome Webbrowser, MyNas und Youtube. Via Online Download oder manuell.

hdstationDownloadApps

… weiterlesen.

Schritt 4: Geräte anschließen (wenn nicht schon geschehen)
Ok – jetzt wird es Zeit den TV oder Receiver via HDMI an das QNAP anzuschließen. Ebenso eine USB-Tastatur sofern keine Qnap Fernbedienung vom NMP-1000 vorhanden ist.

Solltet ihr jetzt noch keine Anzeige auf dem TV haben, startet das NAS einmal neu. (Entweder Power-Button drücken, oder “reboot” via SSH eingeben).
Die HD Station braucht etwas mehr Zeit zum booten. Kann auch noch +5min dauern nach dem Pieps….
Schließlich werdet ihr mit folgendem Bildschirm begrüßt:

Schritt 5: Sprache einstellen
Navigiert wird mit den Pfeiltasten, Entertaste der Tastatur  (oder QNAP Fernbedienung)
1-Install

So nun seit ihr auf dem Startbildschirm der HD Station. Ihr könnt entweder Anwendungen starten, oder erst einmal in die Einstellungen blicken.
Die sind es auf jeden Fall Wert ;-)
2-Configure

Schritt 6: Auflösung wählen
In den Einstellungen könnt ihr die Auflösung einstellen.
3-Resolution

Schritt 7: GGf. Fernbedienung einrichten
Besitzt man eine MCE (Windows Media Center) Fernbedienung kann man diese aktivieren, wenn man diesen Typ in den Einstellungen auswählt
4-Remote

Schritt 8: Auto Start von Anwendung einrichten
Da ich nur XBMC benutzt möchte ich auch dass diese Anwendung automatisch startet. Dazu in den Anwendungseinstellungen den Autostart aktivieren.
6-AutoStart

So jetzt können wir das erste mal in’s XBMC starten.
Hier muss der Audio Ausgang eingerichtet werden, die Darstellung angepasst und der Netzwerkzugriff fürs Handy.

Schritt 9: Bildschirm kalibrieren
Unter System -> Einstellungen -> System -> Bildschirm kalibrieren könnt ihr XBMC an euren Fernseher anpassen.
BildschirmKalibrieren

Schritt 10: Web-Interface aktivieren (für Android/iOS Apps)
Damit ihr mit eurem Handy das XBMC fernsteuern könnt, muss das Webinterface aktiviert werden und die Steuerung von entfernten Programmen zugelassen werden.
WebinterfaceXBMC

Schritt 11: Audio Ausgabe konfigurieren
Um HDMI-Passtrough Ton sowie DTS, Dolby Digital etc. 5.1 auf eurem Receiver bzw. TV auszugeben muss noch etwas komplizierter die Ausgabe eingestellt werden.
Bei meinem QNAP-TS569L muss folgendes als Ausgabegerät konfiguriert werden:

Benutzerdefiniert
plughw:0,3

AudioSettings
Bei einem anderem QNAP Typ kann der Wert anders sein. Du bekommst ihn raus indem du via SSH folgenden Befehl absetzt:

/usr/sbin/chroot /share/MD0_DATA/.qpkg/HD_Station /usr/bin/aplay -l

Der Wert setzt sich aus “card=0″ also 0 sowie “device=3″ also 3 zusammen. Ergibt plugwh:0,3

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
Subdevices: 0/1
Subdevice #0: subdevice #0

Weitere Infos gibt’s dazu im passendem Thread im Forum.

Wie ihr sehen könnt, bekommt mein Receiver 5.1 Ton via HDMI:
AudioOutputReceiver

Troubleshooting:

Die HDStation startet nicht – bzw. man bekommt keine Anzeige via HDMI:
Bei mir war es so, dass wenn mehr als 3GB Ram verbaut war, die HD Station nicht startet.

Meine Fernbedienung funktioniert nicht:
Beachtet beim ersten Start, dass ihr in den Einstellungen der HD Station den Typ der Fernbedienung (QNAP oder MCE) einstellen könnt. QNAP ist Standard.

Automatisches aktualisieren der Datenbank:
XBMC bietet von Haus aus nur die Funktion, beim Start zu aktualisieren. Da das beim NAS eher unwahrscheinlich ist gibt es ein Auto Update Library Addon. Damit lässt sich zeitgesteuert die Datenbank aktualisieren. Infos hier.

Gibt es ein HD Station App fürs Handy?
Noch nicht. Allerdings wird es App’s für iOS sowie Android gegen Anfang 2013 (Q1) geben. Bis dahin muss die Tastatur herhalten ;-)

Kann man ein CD / DVD-Laufwerk anschließen ?
Nein dies ist noch nicht möglich. Vielleicht wird es in Zukunft erweitert.

XBMC hängt – bzw. lässt sich nicht immer via Handy steuern:
Wenn man eine große Datenbank >100 Filme hat und diese das erste mal einliest kann es sein das eingaben via Webinterface nicht verarbeitet werden, oder sogar man nur einen schwarzen Bildschirm angezeigt bekommt. Einfach abwarten bis der Scan abgeschlossen ist. GGf. könnt ihr noch via SSH nachschauen. “top” eingeben, dort sollte dann XBMC erscheinen. (Hat bei mir über Nacht geladen.)

Beim Abspielen von Filmen habe ich Artefakte oder horizontale Linien im Bild!
Im Moment gibt es noch Artefakte bei Filmen mit hoher Bitrate oder DTS/DTS-HD Audio. Ebenso wie Horizontale Linien. Dieses Problem wird hoffentlich bald durch einen neuen Treiber von Intel behoben.

Ich bekomme nur einen Shell Login Screen anstatt der HD Station angezeigt!
Die HD Station läuft auf einem X-ORG und demnach sind 3 verschiedene Screens verfügbar. Durch drücken von “STRG+ALT+F1/F2/F3″ könnt ihr zwischen den Screens wechseln.

 

 

Comments (27)

  1. Simon

    Also bei mir funktioniert es so leider nicht mit meinem TS-469l. Hab es über die Console versucht haber er gibt mir mit dem Befehl immer noch dieses hier aus “[/] # /usr/sbin/chroot /share/MD0_DATA/.qpkg/HD_Station /usr/bin/aplay -l
    chroot: cannot change root directory to /share/MD0_DATA/.qpkg/HD_Station: No such file or directory”

    Auch wenn ich in XBMC pughw:0,3 eingebe bekomme ich keinen Sound.
    Wäre sehr dankbar wenn mir jemand helfen kann.

    • Servus,
      je nach Raid konfiguration kann es bei jedem anders aussehen, hangel dich mal so durch die Ordner:
      /share/MD0_DATA/.qpkg/
      (MD0 Variiert je nach konfig.)

      • Simon

        Diese Ordner gibt es bei mir nicht. /share finde ich, aber MD0_DATA usw. find ich nicht. Muss ich vielleicht vorher irgendwelche Einstellungen am NAS vornehmen?

        • mach mal ein:
          ls -al /share/

          je nach Raid Konfiguration kann der Ordner unterschiedlich sein. Du kannst das so direkt nicht beeinflussen.

          alternativ ein:
          find / -name “.qpkg”

          sollte auch helfen :-)

          • Simon

            Ok ich hab das Problem! Es liegt an meinem Samsung Fernseher der keine DTS durchschleifen kann. Hab mir nun nen HDMI Switch auf Optical Audio bestellt. Hoffe das es mit dem dann funktioniert.

            Danke für deine Hilfe

  2. Peter

    Hat jemand bei der aktuellsten 11.1 Version von XBMC auch das Problem, dass sich plötzlich ein Fenster über das Konfigurationsfenster(Keyboard Eingabemaske) der AudioHW lagert? Bei mir hilft dann nur noch ein restart von XBMC?!

  3. Stefan

    Hi, cooler Artikel,
    ich habe das TS469L.
    und nutze auch das XBMC in der HD Station.
    weist Du ob das Karatelight auch gehen könnte am qnap?
    http://ca.rstenpresser.de/index.php/control-software.html

    Danke

    • Sieht leider nicht danach aus. Einfach das Addon installieren wäre ja kein Problem – aber die Bibliotheken müsstest du manuell nachinstallieren.
      Dann noch die Frage, wie die Module per USB erkannt werden, da fehlt dann ggf. auch noch ein Kernel Modul etc…. schreibst am besten mal als Feature Request ins Qnap Forum: http://forum.qnap.com/viewforum.php?f=24

      Gruß
      Constey

      Auszug:
      IMPORTANT NOTE: Currently DFAtmo has special requirements on its
      dependencies! DFAtmo will not work with the current “officially” released
      XBMC nor will it work with xinelib base media players that
      are compiled against the currently “officially” released xinelib.

  4. Hans Trepel

    Hi …

    gibt es eine möglichkeit das XVDR Plugin zu installieren (als client) um auf VDR zuzugreifen ?

  5. jellyBoss

    Zunächst Dank an Constey für das illustrierte How-to!
    Die Installation auf meinem TS-469L hat geklappt, allerdings vermisse ich PVR-Client add-ons für Live-TV-Wiedergabe. Als Quelle soll mein yaVDR-Rechner dienen, als PVR-Client wäre VNS oder XVDR das richtige.
    Gibt’s diese XBMC-add-ons schon für die QNAP Atom ?

    Gruß,
    jellyBoss

    • Servus,
      leider gibt’s noch keine Möglichkeit xvdr zum Rennen zu bringen. Man könnte sich zwar eine eigene Ubuntu installation als chroot einbinden – aber das ist doch sehr gefrickel.
      Im Moment fürchte ich bleibt uns erst einmal keine andere Wahl als zu warten und hoffen, dass bald ein XBMC v12 Paket kommt, da ist das ja bereits integriert.
      In der Hoffnung, dass Intel dann bis dahin auch was am Treiber nachgebessert hat.
      Gruß
      Constey

    • BOFH

      Kann das 469L auch FullHD in 1080p

  6. peanut0815

    Vielen Dank für diese Anleitung. Ohne Deine Anleitung hätte ich keinen Ton.

    Bei mir war es folgene Einschätzung:

    plughw:0,3

  7. Trouble

    Hallo,

    trotz der Info seitens der TS-869L, zeigt auch card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0],
    und der entsprechenden Konfiguration in XBMC kein Ton nur eine Art Rauschen und Störgeräusche.
    Dann habe ich auch immer wieder Tearing in den Testfiles.
    Diese werden von dem internen Player im meinem Panasonic TV ohne Probleme wiedergegeben.

    Gibt es weitere Tipps zur Konfiguration?

    ..oder ist ein Update in Sicht?

    cu

  8. Dominic

    Hallo,

    seit heute läuft mein Qnap 469L mit der HD Station und XBMC
    Leider habe ich bei BD Is bzw m2ts in 1080p ordentliche Ruckler.
    An meinem TV liegt es 10000%ig nicht, der Pioneer kann echtes 23,9x Hz und mit meinem BD Player läuft alles ganz geschmeidig.

    Die Artefakte und den Versatz des Bildes habe ich leider auch.
    Gibt es da mitlerweile eine Abhilfe ?
    Wird bei der Bildwiderholfrequenz auf “angepasst” gestellt ?
    Was ist noch zu beachten ?
    Was ist mit dem Speicher? reichen die 1GB ab werk oder sidn 2 bzw 3 PFLICHT?

    DANKE

    Dominic

    • Servus,

      da hat sich bis jetzt leider immer noch nichts verändert. Es gibt keinen gescheiten Treiber von Intel :-(
      Zum RAM: “2. Upgrading to 2GB of RAM is recommended for better experience (max 3GB)” http://forum.qnap.com/viewtopic.php?f=295&t=69474
      Ich hab die HD Station noch nicht mit weniger RAM getestet – ich habe aber beim Abspielen von hochbitratigen MKV’s keine Probleme. Also jedenfalls kein Ruckeln.
      Die Artefakte sind leider ab und zu bei jeder Wiedergabe da :-(
      Die Einstellung der Bildwiederholungsrate hab ich nicht im Kopf – ich glaube ich hab die bei mir auf dem Standardwert stehen.

  9. Jeremy

    Hallo Constey,
    zunächst vielen Dank für deine ausführlichen Beschreibungen und all die Infos. Ich denke momentan über den Kauf eines NAS nach. Neben den Standardfunktionen (Massenspeicher für mehrere Benutzer, Backup) möchte ich das NAS auch als HTPC nutzen (TV ist eine Panasonic TX-L42V20E). Qnap scheint mit XBMC gut ausgerüstet zu sein. Hast du schon mal ausprobiert ob mit XBMC und DVB-S2-Tuner TV-Sendungen aufgezeichnet werden können? Qnap bietet lauf Website über die Apps eine solche Möglichkeit an, aber funktioniert das auch über die HD-Station umd XBMC?

    Danke und Gruß
    Jeremy

    • Also das Aufnehmen funktioniert mittels TV-Station. Den XBMC als PVR nutzen hat soweit mir bekannt ist hat aber noch niemand versucht.
      Ich habe aber hier etwas gefunden, was ein TV-Headend bereitstellt – XBMC könnte damit wahrscheinlich umgehen, ich habe das aber weder ausprobiert, noch mich groß eingelesen. Schau am besten mal selbst, ob es hierzu näheres gibt.
      http://www.xbmcnerds.com/index.php?page=Thread&threadID=18166 bzw. http://forum.qnap.com/viewtopic.php?f=276&t=52511

      Mein Tipp: Wenn du deinen HTPC auch aktiv zum Fernsehen nutzen willst, oder viel Wert auf Bildqualität legst – hol dir einen Zotac – die QNAP’s sind im Moment jedenfalls nicht dafür ausgelegt. Gibt noch Treiberprobleme mit dem Intel Prozessor, sodass XBMC bei der Wiedergabe auch leichte schlieren und Grafikfehler mitbringt. (Betrifft aber die Synology NAS Systeme ebenfalls, da die gleiche Intel Atom CPU verbaut ist.)
      Gruß
      Constey

      • Jeremy

        Danke für die Antwort. Ich habe mir vor 2 Jahr von ASRock einen HTPC gekauft.
        dort läuft Win7 und ich nutze MediaPortal zum Aufnehmen von TV-Sendungen. Das funktioniert sehr zuverlässig. Meine Idee war: mit dem NAS könnte ich eine “Komplettsystem” erhalten. Dafür scheinen die aber noch nicht ausgelegt zu sein, wie du sagst. Ich werde erstmal bei meiner Lösung bleiben und das NAS als normalen Netzwerkspeicher nutzen.
        Gruß
        Jeremy

  10. Hallo. Ich habe seit kurzen einen neue Qnap TS-670 Pro. Dort habe ich HD-Station 1.08 laufen und XBMC 12. Die Qnap ist über ein HDMI Kabel an einem Pioneer LX-87 angeschlossen. Leider bekomme auch ich überhaupt kein Tonsignal raus. Wenn ich ein MP3 Song abspiele bekomme ich keinen Sound, wenn ich einen Film abspiele bekomme ich ebenfalls keinen Sound. Bin jetzt eigentlich schon alle Einstellungen die unter System/Audio sind durchgeangen. Hast du vielleicht noch einen Idee was ich probieren kann?

    • Hast du “Schritt 11: Audio Ausgabe konfigurieren” durchgeführt ?

      • Danke Constey füre deine schnelle Antwort !!!

        Ich habe jetzt mal via SSH den Befehl den du unter 11 genannt hast abgesetzt und folgendes Resultat bekommen:

        **** List of PLAYBACK Hardware Devices ****
        card 0: PCH [HDA Intel PCH], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
        Subdevices: 1/1
        Subdevice #0: subdevice #0
        card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
        Subdevices: 1/1
        Subdevice #0: subdevice #0
        card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
        Subdevices: 1/1
        Subdevice #0: subdevice #0

        Hast du einen Tip was ich jetzt machen muss

        • Bei Audio Ausgabegerät habe ich 5 Möglichkeiten:

          - HDA Intel PCH, PIO SC-LX87 on HDMI
          - HDA Intel PCH, HDMI
          - HDA Intel PCH, ALC662 rev1 Analog
          - Default (HDA Intel PCH HDMI 1)

          Eine benutzerdefinierte Einstellmöglichkeit wie oben auf deinem Bild scheint es nicht mehr zu geben

          Eine Beenu

  11. Dan

    Ich besitze einen Qnap TS 469L; xbmx funktionierte immer einwandfrei. Seit ein paar Wochen hängt sich xbmc rd. 5s nach dem Start auf; lädt unaufgefordert nicht vorhandene mp3´s. Trotz Neuinstallation von HD-Station als auch xbmc ist der Fehler weiterhin vorhanden. Was kann man noch unternehmen? Bin für jeden Tip dankbar.

    Gruß, Dan

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *